Server serving up EVERY playlist to clients

Feel free to post bug reports here. I need exact, detailed steps showing me how I can re-create the bug on my machine, so give as much info and detail as possible.
Post Reply
DeusExMachina
Posts: 1280
Joined: Sun Apr 20, 2008 9:57 am
Location: Pittsburgh, PA
Contact:

Server serving up EVERY playlist to clients

Post by DeusExMachina » Sat Oct 27, 2018 8:44 pm

Did we ever figure this out?
Sometimes the server machine refuses to send the standard singer playlists to certain browsers on certain machines, but instead serves up EVERY playlist on the host machine!
Screen Shot 2018-10-27 at 11.32.43 PM.png

User avatar
dave
Site Admin
Posts: 6354
Joined: Sun Sep 18, 2005 8:02 am
Location: Seattle
Contact:

Re: Server serving up EVERY playlist to clients

Post by dave » Thu Nov 01, 2018 10:26 am

umm, i thought we did! ugh! you're still seeing it on the latest?

DeusExMachina
Posts: 1280
Joined: Sun Apr 20, 2008 9:57 am
Location: Pittsburgh, PA
Contact:

Re: Server serving up EVERY playlist to clients

Post by DeusExMachina » Thu Nov 01, 2018 11:07 am

Yup. And can make no heads or tails as to why. Even on the same machine, same singer, Firefox might do it, but Safari will be fine. Or Plainview (a kiosk that uses webKit) might screw up, but Firefox will load it just fine.
It's SO weird. Something odd on the server end, definitely.

User avatar
dave
Site Admin
Posts: 6354
Joined: Sun Sep 18, 2005 8:02 am
Location: Seattle
Contact:

Re: Server serving up EVERY playlist to clients

Post by dave » Thu Nov 01, 2018 3:14 pm

i do remember addressing that problem, but don't remember when

i looked over the history and found nothing about it :(

DeusExMachina
Posts: 1280
Joined: Sun Apr 20, 2008 9:57 am
Location: Pittsburgh, PA
Contact:

Re: Server serving up EVERY playlist to clients

Post by DeusExMachina » Thu Nov 01, 2018 6:27 pm

Any idea what might be the distinction on the client side? Wondering if the request being passed to the server from the client that populates that list is somehow being passed by the server to deliver something that it shouldn't. Like, since playlists aren't hardwired, it has to be something in how kJams decides to populate the variable that is then used to populate the data served back to the client.

At this point I am more curious than expectant of a solution (as I can always work around it by launching another browser.)

User avatar
dave
Site Admin
Posts: 6354
Joined: Sun Sep 18, 2005 8:02 am
Location: Seattle
Contact:

Re: Server serving up EVERY playlist to clients

Post by dave » Wed Nov 07, 2018 12:22 pm

hmm, i think the problem was in the javascript or html (server folder) code? and you actually fixed it?

DeusExMachina
Posts: 1280
Joined: Sun Apr 20, 2008 9:57 am
Location: Pittsburgh, PA
Contact:

Re: Server serving up EVERY playlist to clients

Post by DeusExMachina » Sat Nov 10, 2018 3:09 pm

I think I fixed something else that on SOME machines bypassed the issue entirely. But I think the issue was still there, and it's come back to bite me/us.

User avatar
dave
Site Admin
Posts: 6354
Joined: Sun Sep 18, 2005 8:02 am
Location: Seattle
Contact:

Re: Server serving up EVERY playlist to clients

Post by dave » Sun Nov 11, 2018 9:27 pm

urrrk. if i can get a repro case.... i can fix it!

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests